Tool Update - can we run on top of the old one?

Oct 4, 2012 at 1:12 PM

Will,

You mentioned that you have posted a new version of the migration tool - can you give some instructions on how to run it?

Specifically - do we just install over the beta and run it again and it will handle any existing migrations or do we have to roll back the database and start from scratch?

Thanks

Oct 4, 2012 at 10:10 PM
Edited Oct 4, 2012 at 10:11 PM

I would just remove the old one and install the new version. 

However, I think, the important question is whether AF5 is stable enough to upgrade? We cannot use the migration script without AF5. I still see lots of errors/complaints about AF5 and worry about upgrading a perfectly working AF4 to AF5.

I just saw that Chris Hammond is working on AF5 but unfortunately only in his non-office spare time. He works for DNN Corp. I like him and think he will honest and communicate with us. Hopefully he can do as much as possible and as fast as he can to stabilize AF5.  

Coordinator
Oct 4, 2012 at 10:20 PM
PokerDIY wrote:

Will,

You mentioned that you have posted a new version of the migration tool - can you give some instructions on how to run it?

Specifically - do we just install over the beta and run it again and it will handle any existing migrations or do we have to roll back the database and start from scratch?

Thanks

I was under the impression that the migration tool wasn't working at all for anyone?  Are you saying that it did work to some degree for you?  I could really use some more accurate feedback as to what is working and what isn't.  I really don't mind making fixes to this tool and do want it to work for everyone, but I really can't do much with the feedback that has been provided so far.  

You can just install this version over the existing version.  The Journal and Groups should be the only thing you have to worry about with duplicate data.  If those worked before, don't run them again.  

If you have time, when you run this tool again, can you report back in a new thread as to what worked and what didn't?  

Oct 4, 2012 at 10:34 PM

Hmm - I see I did not mention that it partially worked in my post - http://activesocial.codeplex.com/discussions/395815

In the beta, every step failed - however I have some Journal Posts (not all I don't think). I am going to try it over the old one and I will report here in detail and I will also then roll it back to the Live state and try the new version again and report back)

Oct 4, 2012 at 10:59 PM

Will, I very specifically stated that the tool worked for me all the way up to the Journal Migration and I provided a specific error from my server event logs and also sent a copy of my journal entries. Because I got an instant error I thought the journal migration was failing immediately. Today I got a little smarter and looked at the new Journal table. I see that it did import six records. So I installed the new script and just ran the journal migration. Same six records imported. Is there some place that I can go see what error logging you captured with the new version?

Also, if you can tell me the order in which you are trying to do the import I might be able to figure out which record would come next and see if there is anything specific about that record that is causing the issue. It isn't just importing records sequentially or in DateCreated order. I see you have an ObjectKey with entries like AS2, AS4. Is this the Active Social Journal ID?

Again if you can help me figure out what the import order is and what record it is failing on I can take a look at it.

Oct 5, 2012 at 2:35 AM

Will,

My post is here.

http://activesocial.codeplex.com/discussions/396084

You can do something with the feedback you have. Most of us have offered you access to our websites so you can check it yourself. Have you contacted anyone to check it out? 

Again, it did migrate some things to the new DNN Social but the imported things are random and not complete. 

Nov 24, 2012 at 12:18 PM

I even have the active social support (paid support) that is no longer offered on dnnstore, but I had purchased it before they yanked it from the store.

I have been writing them via the support help desk, and still not receiving any response. 

My current status:

1) I have currently 31000 entries on my journal.  I am okay with getting rid of all of them.

2) Private Messages can all be wiped away.

3) I didnt do any modification to the default user profiles.

4) I have 0 groups.

5) I am using the Active Forums - 4.3.8

6) I am using the Active Forums Whats Up Module - 1.4.8

7) I have ActiveSocial 1.9.6 installed

 

What is the best step to proceed?